No components marked as affected
Resolved
The issue has now been resolved
Monitoring
We've released a fix and now are monitoring the System
Identified
We've identified the cause of the Degraded Performance on our site.
Our team is working on a fix and we expect to have this resolved within 15 minutes.